Problème d’affichage du widget Tabs avec jQuery UI [Résolu]

Home Forums Javascript / jQuery jQuery Problème d’affichage du widget Tabs avec jQuery UI [Résolu]

  • Ce sujet contient 3 réponses, 2 participants et a été mis à jour pour la dernière fois par Wanbdi, le il y a 6 années et 11 mois.
4 sujets de 1 à 4 (sur un total de 4)
  • Auteur
    Messages
  • #174
    Patoche
    Invité

    J’utilise Jquery UI 1.9.1 avec jQuery 1.8.2, lorsque j’utilise le widget Tabs les contenus des tabs sont affichés l’un après l’autre. Le display hidden ne fonctionne pas. J’ai tester en mettant le code d’exemple du site
    http://jqueryui.com/tabs/%5DJquery UI et ça marche pas non plus ? 🙁

    #175
    Julien
    Maître des clés

    Le problème vient de l’utilisation de la balise, tu dois avoir dans ta page du code du genre

    <base href="http://urldebasedetonsite/" />

    Si tu supprimes la balise tout va fonctionner correctement.

    • Cette réponse a été modifiée le il y a 6 années et 11 mois par Julien.
    #202
    Patoche
    Invité

    Génial ça marche nickel 🙂

    #203
    Wanbdi
    Invité

    Si tu ne peux pas supprimer le tag <base> de ton site, une autre solution : mettre dans le lien des ancres de chaque tab le lien vers la page courante :

    ça bug

    <a href="#">Tab 1</a>

    ça bug plus

    <a href="mapage.htm#">Tab 1</a>

    Wanbdi en Sioux signifie Aigle 🙂

4 sujets de 1 à 4 (sur un total de 4)
  • Le sujet ‘Problème d’affichage du widget Tabs avec jQuery UI [Résolu]’ est fermé à de nouvelles réponses.